La descarga está en progreso. Por favor, espere

La descarga está en progreso. Por favor, espere

ESTRUCTURAS DE DECISIÓN SENA. ESTRUCTURAS DE DECISIÓN ESTRUCTURAS SELECTIVAS ALTERNATIVA SIMPLE: Se identifican porque están compuestos únicamente de.

Presentaciones similares


Presentación del tema: "ESTRUCTURAS DE DECISIÓN SENA. ESTRUCTURAS DE DECISIÓN ESTRUCTURAS SELECTIVAS ALTERNATIVA SIMPLE: Se identifican porque están compuestos únicamente de."— Transcripción de la presentación:

1 ESTRUCTURAS DE DECISIÓN SENA

2 ESTRUCTURAS DE DECISIÓN ESTRUCTURAS SELECTIVAS ALTERNATIVA SIMPLE: Se identifican porque están compuestos únicamente de una condición. La estructura si_ entonces evalúa la condición y en tal caso: Si la condición es verdadera, entonces se ejecuta la acción SI, si la condición es falsa no se hace nada. SI condición ENTONCES Acción si FIN SI S

3 Ejercicio Desarrollar un algoritmo que lea un número e imprima si es positivo.

4 Solución Variables: numero: Entero. Inicio Lea numero SI numero > 0 Imprimir El número es positivo. FIN SI Fin

5 Ejemplo Hacer un algoritmo que lea los nombres y edades de dos personas e imprima cual de ellas tiene más edad.

6 Solución Variables: edad1, edad2: Entero Variable nombre1, nombre2: Cadena Inicio Mostrar(Ingrese tu nombre1 y tu edad1) LEA (nombre1, edad1) Mostrar(Ingrese tu nombre2 y tu edad3) LEA (nombre2, edad2) Si edad1 > edad2 imprimir (La persona mayor es) Imprimir(nombre1) Fin Si Si edad2 > edad1 imprimir (La persona mayor es) Imprimir(nombre1) Fin Si Si edad1 = edad2 imprimir (Las dos personas tienen igual edad) Fin SI FIN

7 Ejercicio Hacer un algoritmo que calcule el valor de la compra de un producto. Si el valor de la compra es mayor a se aplica al valor de la compra un descuento del 10%. El algoritmo debe mostrar el total de la compra

8 Ejercicio Hacer un algoritmo que muestre un mensaje Eres mayor de edad Si la edad es igual a 18. La edad la ingresa el usuario.

9 ALTERNATIVA DOBLE Son estructuras que permiten controlar la ejecución de varias acciones y se utilizan cuando se tienen dos opciones de acción, por la naturaleza de estas se debe ejecutar una o la otra, pero no ambas a la vez. IF condición THEN Acción si ELSE Acción sino ENDIF Ejemplos

10 Ejercicio Desarrollar un algoritmo que lea un número e imprima si es positivo o negativo.

11 Ejercicio Inicio num=0 num>0 Si El numero indicado es positivo 1 No El numero indicado es negativo Fin 1

12 Solución Variables: numero: Entero Inicio Lea numero IF numero > 0 THEN Imprimir El número es positivo. ELSE Imprimir El número es Negativo. ENDIF Fin

13 Ejercicio Dado como dato el valor total de una compra, aplicar un aumento del 6 % si la compra es inferior a o 3% en caso contrario, imprimir el nuevo valor a pagar.

14 Solucion Variables: valorCompra, valorAumento, totalPagar: Real Inicio Lea valorCompra IF valorCompra <= THEN valorAumento valorCompra * 0.06 ELSE valorAumento valorCompra * 0.03 ENDIF totalPagar valorCompra + valorAumento Imprimir El total a pagar con aumento es:. totalPagar Fin

15 Ejercicio Realizar un algoritmo que a partir del sexo ingresado por el usuario, muestre un mensaje indicando si es hombre o mujer.

16 Ejercicio Realizar un algoritmo en donde se pide la edad del usuario; si es mayor de edad debe aparecer un mensaje indicándolo.

17 Ejercicio Se pide leer tres notas del alumno, calcular su definitiva y enviar un mensaje donde diga si el alumno aprobó o reprobó el curso. Aprobo el curso si la definitiva es > 3 Definitiva=(n1+n2+n3)/3

18 ESTRUCTURAS DE DECISION ANIDADAS. Es posible utilizar la instrucción If para diseñar estructuras de selección que contengan más de 2 alternativas. Esta sería una de las formas como se podría realizar una estructura anidada, mas no es la única forma de realizarlo: Nota: Por cada if que se abra, debe tener su respectivo endif.

19 ESTRUCTURAS DE DECISION ANIDADAS. IF condicion1 THEN Acción ELSE IF condicion2 THEN Acción ELSE IF condición 3 THEN Acción ELSE ……… ENDIF Ejemplo Ejemplo 11

20 Ejercicio Se desea escribir un algoritmo que pida la altura de una persona, si la altura es menor o igual a 150 cm envíe el mensaje: Persona de altura baja; si la altura está entre 151 y 170 escriba el mensaje: Persona de altura media y si la altura es mayor al 171 escriba el mensaje: Persona alta. Exprese el algoritmo usando Pseudocódigo y diagrama de flujos.

21 Ejercicio

22 Solución ALGORITMO INICIO Variable Altura: ENTERO ESCRIBA Cuál es tu altura? LEA Altura Si Altura 170 ENTONCES ESCRIBA persona alta Fin-Si Fin-Si Fin-Si FIN

23 Ejercicio Un almacén realiza una promoción en la cual se hace un descuento teniendo en cuenta las cantidades compradas de un producto, se conoce el valor unitario y las cantidades adquiridas del producto: Si las unidades son menores o iguales a 3 no hay descuento, si es mayor de 3 y menor o igual de 5 el descuento es del 5%, si es mayor de 5 y menor o igual de 12 es de 8% de lo contrario se le otorga el 10%. Calcular el valor total a pagar por el cliente.

24 Solución Variables: unidades, valorUnit, totalPagar, dto, valorCompra: Entero Imprimir El valor a pagar aplicando el descuento es de:. totalPagar Fin

25 Ejercicio Desarrollar un algoritmo que lea 3 números diferentes A, B, C y mostrar el mayor.

26

27 Ejercicio El supermercado Euro realiza una promoción en la cual se hace un descuento teniendo en cuenta el valor de la compra. El usuario proporcionara la siguiente información valor de los articulos y cantidad. Si el valor de la compra es meno o igual a se le descuenta 100. Si el valor de la compra es mayor que pero menor que se le descuenta 500. Si el valor de la compra es mayor que se le descuentan El algoritmo debe mostrar el valor de la compra antes de aplicarle el descuento. Y el nuevo valor de la compra después de aplicado el descuento.


Descargar ppt "ESTRUCTURAS DE DECISIÓN SENA. ESTRUCTURAS DE DECISIÓN ESTRUCTURAS SELECTIVAS ALTERNATIVA SIMPLE: Se identifican porque están compuestos únicamente de."

Presentaciones similares


Anuncios Google